The other day, I was setting an Active Directory lab using VMware workstation 12. After I installed Windows Server 2016 and Windows 10 client, they wouldn’t communicate each other.

  1. So I went to “Virtual Machine Setting” menu and tried to change their network setting from NAT to Bridge.Capture000.PNG

And when I click ‘Okay’ button, it kept returning the following error message;

The network bridge on device ‘VMnet0’ is not running. The virtual machine will not be able to communicate with the host or with other machines on your network. Failed to connect virtual device ‘Ethernet0’.

Capture008.PNG

 

  1. Let’s go check network adapter settings of the host computer(physical computer, not the virtual machine).

Go to either

Control Panel -> View network status and tasks (under ‘Network and Internet’)

or

Control Panel -> Network and Sharing Center

 

If you see a screen like below, click ‘Change adapter settings

Capture001.PNG

 

  1. You will see a list of network adapters. Choose one that you use to connect the internet(Probably ” Ethernet ” or “Wi-Fi‘ “). Right-click on the chosen adapter’s name and click “Properties

Now, it seems bridge protocol is missing. Follow the steps below to add “VMware Bridge Protocol

Click “Install” -> “Service” -> “VMware Inc” -> “VMware Bridge Protocol”

Capture002.PNG

Capture003.PNG

Capture004.PNG

 

  1. Reboot your host computer. Try to change virtual machine network connection setting to “Bridge” Capture005.PNG

4 COMMENTS

LEAVE A REPLY

Please enter your comment!
Please enter your name here